DocupeakCloud Service - Interruption Alert

Incident Report for PairSoftCloud

Resolved

This incident has been resolved.
Posted Dec 04, 2024 - 16:09 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2024 - 09:08 EST

Investigating

We are currently experiencing minor performance issues with the Docupeak Cloud Service. Our Teams are actively working on the remediation. Please check here periodically for updates. We apologize for any inconvenience.
Posted Dec 04, 2024 - 09:03 EST