PaperSaveCloud OCR Service Alert

Incident Report for PairSoftCloud

Resolved

This incident has been resolved.
Posted Oct 23, 2024 - 10:32 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2024 - 17:31 EDT

Investigating

We are experiencing minor issues with the PaperSave OCR. Our Teams are actively working on the remediation. Please check here periodically for updates. We apologize for any inconvenience.
Posted Oct 22, 2024 - 15:36 EDT