PaperSaveCloud Service Interruption Alert

Incident Report for PairSoftCloud

Resolved

This incident has been resolved.
Posted Dec 12, 2024 - 13:00 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2024 - 12:35 EST

Identified

We are currently experiencing minor disruptions with the PaperSaveCloud services, which may temporarily affect access to certain features of your PaperSave application. Our team is actively working to resolve the issue. We appreciate your patience and recommend checking here for updates. We apologize for any inconvenience caused.
Posted Dec 12, 2024 - 11:53 EST