PaperSave Operations Service - Interruption Alert

Incident Report for PairSoftCloud

Resolved

This incident has been resolved.
Posted Aug 19, 2024 - 15:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2024 - 14:16 EDT

Investigating

We are currently experiencing performance issues with the PaperSaveCloud Operations Service. These may prevent you from using your PaperSave account, or you may experience intermittent response time when logging-in.
Our Teams are actively working on the remediation. Please check here periodically for updates. We apologize for any inconvenience.
Posted Aug 19, 2024 - 13:46 EDT