Microsoft has informed us that the issues on their datacenter are resolved, and systems are recovering. Our teams keep on working on improving stability and enhancing customer experience. During the weekend we will perform extended regression testing in order to validate that our systems and functionalities have returned back to their expected state.
Posted Jan 11, 2025 - 08:16 EST
Update
While the stability of the Microsoft Datacenter is slowly improving, and our mitigating actions are taking effect. We do still see intermittent issues related to the Microsoft outage. Our team is committed in getting these issues resolved as soon as possible (together with Microsoft) and will continue throughout the weekend to ensure maximum stability as soon as possible.
We again apologize for any inconvenience this may cause and appreciate your patience while we resolve the issue. Updates will be provided as soon as more information becomes available.
Posted Jan 10, 2025 - 13:26 EST
Update
We are currently experiencing intermittent issues related to Microsoft outage. Our team is actively working to restore optimal performance as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience while we resolve the issue. Updates will be provided as soon as more information becomes available.
Posted Jan 10, 2025 - 09:55 EST
Monitoring
We are pleased to inform that the environments are back online. In case of any questions feel free to reach out to our support team. We stay in close contact with Microsoft in order to get a good Root Cause Analysis of this outage.
Posted Jan 10, 2025 - 08:13 EST
Update
Microsoft has shown some improvements on their datacenter which allowed us to bring your Papersave environment back online. However, the infrastructure at Microsoft remains unstable. In order to safeguard our service, we continue migrating clients to a different datacenter region. Support will contact you directly when your company has been migrated. All functionalities should be available again after migration, but we stay cautious.
Posted Jan 10, 2025 - 04:00 EST
Update
Microsoft issues still persist. We are actively migrating clients to a different datacenter region. Support will contact you directly when your company has been migrated. Initial migration will allow access into the system but some features will not function as expected. We are working diligently to make the entire application fully functional as soon as possible.
Posted Jan 09, 2025 - 16:21 EST
Update
We are continuing to investigate this issue.
Posted Jan 09, 2025 - 14:19 EST
Update
We are actively monitoring the situation and working with Azure support to stay updated on progress. As of now, there is no estimated time for resolution. We will provide further updates as soon as we receive more information. Thank you for your patience and understanding.
Posted Jan 09, 2025 - 05:54 EST
Investigating
There is an ongoing outage reported in the datacenter of Microsoft that is affecting our services. This issue may have a direct impact on our applications, particularly on the PaperSave Services. Our team is closely monitoring the situation and coordinating with Microsoft support to minimize the impact on our operations. For your reference we have also added the status page of Microsoft where you can see the communication from Microsoft. (https://azure.status.microsoft/en-us/status)
Posted Jan 09, 2025 - 03:03 EST
This incident affected: PaperSave 7 Services (Operations Service (PSLAAS01P), Operations Service (PSLAAS02P), Operations Service (PSLAAS03P), Operations Service (PSLAAS04P), Operations Service (PSLAAS05P), Operations Service (PSLAAS06P), Operations Service (PSLAAS07P), Operations Service (PSLAAS08P), Operations Service (PSLAAS09P), Operations Service (PSLAAS10P), Operations Service (PSLAAS01P-BHSN), Operations Service (PSLAAS01P-GTF), Operations Service (PSLAAS01P-USC), PaperSave Web Client (AWS), Workflow Service (PSWFAS01P-RFMC), Authentication Service (PSIDAS01P-BHSN), Workflow Service (PSWFAS01P), Authentication Service (PSIDAS02P), Authentication Service (PSIDAS01P), Workflow Service (PSWFAS01P-SEG), Workflow Service (PSWFAS01P-BHSN), Workflow Service (PSWFAS02P)).