PaperSaveCloud Service Interruption Alert
Incident Report for PairSoftCloud
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 06:17 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2024 - 13:15 EST
Identified
We are experiencing minor issues with the PaperSaveCloud services. These issues may prevent you from accessing or using parts of your PaperSave application. Our Teams are actively working on the remediation. Please check here periodically for updates. We apologize for any inconvenience.
Posted Nov 07, 2024 - 12:57 EST
This incident affected: PaperSave 6 Services (PaperSave 6 and 7 Service (PSAAVM01P)).