PaperSaveCloud Service Interruption Alert

Incident Report for PairSoftCloud

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 13:40 EST

Investigating

Blackbaud has reported an incident regarding Financial Edge where users are unable to see the PaperSave plug-in icon. They have engineers actively working to resolve this issue. Please use the link below for updates on the status of this issue.
https://status.blackbaud.com/ (Blackbaud Status)
Posted Feb 03, 2025 - 13:04 EST