PaperSaveCloud Service Interruption Alert

Incident Report for PairSoftCloud

Resolved

This incident has been resolved.
Posted Dec 03, 2024 - 13:21 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2024 - 13:01 EST

Identified

We are experiencing minor issues with the PaperSaveCloud services. These issues may prevent you from accessing or using parts of your PaperSave application. Our Teams are actively working on the remediation. Please check here periodically for updates. We apologize for any inconvenience.
Posted Dec 03, 2024 - 12:42 EST
This incident affected: PaperSave 6 Services (PaperSave 6 and 7 Service (PSAAVM15P)).