A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2024 - 12:30 EDT
Investigating
We are currently experiencing performance issues with the PaperSaveCloud Operations Service. These may prevent you from using your PaperSave account, or you may experience intermittent response time when logging-in. Our Teams are actively working on the remediation. Please check here periodically for updates. We apologize for any inconvenience.
Posted Aug 07, 2024 - 12:15 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2024 - 15:26 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 06, 2024 - 15:24 EDT
Investigating
We are currently experiencing performance issues with the PaperSaveCloud Operations Service. These may prevent you from using your PaperSave account, or you may experience intermittent response time when logging-in. Our Teams are actively working on the remediation. Please check here periodically for updates. We apologize for any inconvenience.